question

sanjay avatar image
sanjay asked ·

Urgent: Vault Card is not working with Payment connector

Hi @David Marginian @Jeffrey Blattman

We are using a payment connector to make the payment. When we set the valid vault card data in SaleRequest, it is not working as expected, every time forced to swap the card again while a valid vault card is attached with the request.

We are using following code:

SaleRequest request = new SaleRequest();
request.setExternalId(ExternalIdUtils.generateNewID());
long dd = 1000;
request.setAmount(dd);
request.setVaultedCard(response.getCard());
mPaymentConnector.sale(request);


Please suggest.

Thanks.

PaymentsPaymentConnectorSaleclover developer community
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

David Marginian avatar image
David Marginian answered ·
11 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi @David Marginian,

I have tried with the same and found that my card is showing on the Payment screen as attached. But we want to process it directly without showing the payment screen. we don't want to press the option. Is it possible?

0 Likes 0 · ·
payment-screen.png (87.8 KiB)

Unfortunately this is not currently possible with Payment Connector.

0 Likes 0 · ·
sanjay avatar image sanjay David Marginian ♦♦ ·

@David Marginian Is there any other solution?

0 Likes 0 · ·
Show more comments

Welcome to the
Clover Developer Community