question

onusms avatar image
onusms asked David Marginian edited

Clover Mini Connectivity issue using USB PAY DISPLAY

Hello,

We are trying to connect Clover Mini with USB PAY DISPLAY to the CloverExamplePOS.EXE

When we use the Production Live Clover Mini device then it connects successfully but when we try to use Clover Mini Demo Device then it is not connecting. The USB connection itself is not detecting the Clover Mini Demo device on our Laptops.

Note: This issue happens only with the Clover Mini DEMO devices. All other Production and Sandbox devices connect successfully.

So is there anything we need to enable on the Clover mini Demo device to connect it to our POS via USB connection and USB PAY DISPLAY app?


Can you please advise?


Thank you.

Clover Minisemi-integrationsUSB Pay Display
1 comment
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Can someone please advise on this?
0 Likes 0 ·
onusms avatar image
onusms answered David Marginian commented

Hello,

Can someone please advise on this request?

6 comments
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

There is nothing you need to enable (assuming you have installed USB Pay Display on the device and it is running). In a moderator's only comment provide the device's serial number.

0 Likes 0 ·
I don't see anything that stands out on those devices. Are you sure this isn't an issue on the POS side? Can you try connecting to one of these devices and then send us the device logs via the "Diagnostics" app on the device?
0 Likes 0 ·
onusms avatar image onusms David Marginian ♦♦ ·
Yes, David, I am sure it's not an issue from the POS because when I connect the live Clover Mini from our business and a sandbox one then it connects successfully but only has an issue with these DEMO devices.

To help you more on identifying the issue: When we connect the LIVE Clover Mini from our business then it plays a sound of a USB connection on our laptop but when we connect any of these DEMO devices then there is not any sound of a USB connection. So looks like the USB is not detecting the DEMO devices at all.


As you requested, I will connect the device again and provide the device logs in a few minutes.
0 Likes 0 ·
Show more comments
paulryan avatar image
paulryan answered David Marginian edited

Hi David


I’m having same issues on my devkit, my devkit update to android Ron 10 the other day hasn’t work since

3 comments
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Mini 1 isn't getting the Android 10 update.

0 Likes 0 ·
paulryan avatar image paulryan David Marginian ♦♦ ·
Mine is a v2
0 Likes 0 ·

If you are seeing issues since the A10 issue on your Mini 2 please provide us with a logcat and as many other details as possible so we can investigate.

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community