question

tombialy avatar image
tombialy asked ·

DevKit StationPro display went dark

Our DevKit Station Pro went dark and display stoped showing anything. Besides that the core hardware seems ok. We can connect with `scrcpy` and `adb`. As per some previous threads that we found on this forum, we have sent an email to support@clover.com. However, we have not heart anything yet. Is support@clover.com the proper channel for handling broken DevKit's. We bought the device just few months ago and it is very new. Is there any warranty on DevKits? Thanks in advance for any info.

DevKit
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

kelvin avatar image
kelvin answered ·

You can email devkit@clover.com. Our Station Pro had same issue and eventually sent it back to Clover.

1 comment Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Do you know the phone number of devKit support team?

0 Likes 0 · ·
tombialy avatar image
tombialy answered ·

We tried the email thanks for hint. We also talked to customer support at 1-844-864-5449. Unfortunately, nobody knows anything about supporting devKits. They asked me to go back to the community for help while trying to investigate. I am wondering if anybody has more info on support of the devKit devices. Or if we need to purchase another set.

1 comment Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Did you get a response from the devkit email or are you still waiting?

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community