question

sdesai avatar image
sdesai asked ·

pakms api failing in production

We're seeing the /pakms/apikey endpoint failing with {"message":"401 Unauthorized"} in production after the recent migration. Sandbox is working and the auth tokens we tested in production are working fine for other api calls.

e-commerce api
1 comment
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

This is being investigated.

1 Like 1 · ·
David Marginian avatar image
David Marginian answered ·

Also, please note the the pakms/apikey endpoint is not meant to be called per payment. You should be obtaining the token 1 time per merchant, storing it, and pulling it from the store for subsequent payments.

Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian answered ·

This issue has been resolved.

11 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi David. We have been following this thread as we have dozens of apps down due to this issue. As of 2 minutes ago, we are still experiencing this issue.

0 Likes 0 · ·

Provide your app id please. I just checked the logs again and the 401s have dropped off a cliff, I don't see any since 10:45. I am guessing you are getting a lag in your reports.

0 Likes 0 · ·
demskigroup avatar image demskigroup David Marginian ♦♦ ·

Q0F51JYME1A8C

0 Likes 0 · ·
Show more comments

Welcome to the
Clover Developer Community