question

rob.smitha avatar image
rob.smitha asked ·

how to re-associate a device from one merchant to another merchant?

I have multiple test locations under my sandbox account. I re-associated a device from my dev kit to another merchant and was not able to get an app to download using the "Preview In App Market" link on the market listing to work so I would like to move the device back to the previous merchant that is working. However, now the devkits page on my developer account no longer has the device I want to re-associate back to the original merchant.


When I try to manually associated the dev kit by entering the serial number and selecting a merchant, I get the following message: "That device is already activated". I have factory reset the device a couple times, but every time I reactivate it, it is still under the merchant I am trying to move it from.


Please let me know how I can move a device from my devkit between merchants without the device disappearing from my dev kits page. Thanks.

DevKit
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian answered ·

There is an issue with the dashboard. I have created an issue and the team is working on a fix. In the meantime we cleared the associated status of this developer's devkit so he could continue working.

Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian answered ·

"When I click "Associate Dev Kit""

Have you tried clicking the "Reassociate Dev Kit'' link per the documentation I previously sent?

3 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Since the device does not show in my dev kit list, I can't click re-associate device.


Hope this graphic clears up what i'm trying to say.

0 Likes 0 · ·
missingdevice.png (45.7 KiB)

Thanks, that helps. I will check with the developer platform team and get back to you.

0 Likes 0 · ·
rob.smitha avatar image rob.smitha David Marginian ♦♦ ·

Thanks, let me know if you need any more info.

0 Likes 0 · ·
David Marginian avatar image
David Marginian answered ·

Instructions for re-associating the devkit can be found here - https://docs.clover.com/clover-platform/docs/setting-up-your-devkit.

3 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks @David Marginian I have associated/re-associated dev kits before.


The issue is one of my devices is no longer showing in my dev kits list at all after re-associating it to a different test merchant.


When I click "Associate Dev Kit" and enter the "Dev Kit Serial Number", I get the following error message:

"Invalid request: That device is already activated"

NOTE: I have tried factory resetting the device and associating it before it has been activated to no avail.


Is there a limitation to the dev kits I would see under my developer account or some other factor that would cause this device to be removed from my dev kits list?


Here is the url with the dev kits list for your reference:
https://sandbox.dev.clover.com/developer-home/[DeveloperID]/devkits

0 Likes 0 · ·

@David Marginian, rob.smitha is no longer with our company but we are still having this issue.

0 Likes 0 · ·

Will, can you submit a private post and specify what device is not showing up and what merchant you want it assigned to?

0 Likes 0 · ·

Welcome to the
Clover Developer Community