question

MedClove avatar image
MedClove asked ·

Error connecting to payment gateway

Doing some testing on a devkit setting up a semi integration. Our application was working fine yesterday but am getting an error when putting sales through today.

Transaction declined: Error connecting to payments gateway. Please try again later.

Are there any issues in the payment gateway at the moment or is it a "me" issue?
semi-integrationsDevKit
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

hergy80 avatar image
hergy80 answered ·
I had this problem with the REST api. Make sure you're not passing a $0 total value. That's the error it gave me.
Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

MedClove avatar image
MedClove answered ·
Hmm, doesn't look like I'm passing it 0 anyway. The SaleRequest has the amount set correctly at any rate. There is no sales response fired so amn't 100% sure what it's getting.

Getting the same error when using the remote-pay-cloud NodeJS example also.
2 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I assume this is in sandbox? I just ran a sale on sandbox and it was successful.

0 Likes 0 · ·

Yep, it was indeed. But just made another sale there and it also went through fine.
Must have been some intermittent issues.

Cheers for taking a look.

0 Likes 0 · ·

Welcome to the
Clover Developer Community