question

Getti avatar image
Getti asked ·

Invalid credentials error on emultor

I've just created (and activated) dev account in the sandbox environment. I've downloaded Clover: com.clover.engine-1455.apk and App Updater: com.clover.appupdater-1095.apk from sandbox.dev.clover.com/developers/dev-apks . I've installed them on Android tablet with 4.4.2 and on emulator with 4.4 and when I trie to log in I receive message An error occurred while communicating with the server. {"message":"Invalid credentials"}. My credentials are correct because I logged in successfully couple of times in sandbox.dev.clover.com. I also tried with this apk - docs.clover.com/wp-content/uploads/2015/09/com.clover.engine-1452.apk and same result.

Emulator
2 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Can you capture some logs with adb logcat when you try to login on the emulator and put them in a pastebin.com ?

0 Likes 0 · ·

Here is the log - http://pastebin.com/2iiiyGG4

0 Likes 0 · ·

1 Answer

Mike M avatar image
Mike M answered ·

This is currently a known bug in Sandbox. Can you please run this script via terminal to update your environment url? target_sandbox.sh

[EDIT] updated script link to dropbox

4 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

OK. But I don't have access to the file : You need permission. I've requested access.

0 Likes 0 · ·

Sorry about that, can you please try again.

0 Likes 0 · ·

Thanks. Now it's working. After I executed the script I was able to log in. Thanks again.

0 Likes 0 · ·

The link there seems to of been moved. This thread mentions the link: http://devask.clover.com/question/204...

0 Likes 0 · ·

Welcome to the
Clover Developer Community