question

ramya avatar image
ramya asked David Marginian commented

ACTION_SECURE_PAY not working on Clover Station Solo

Hi,

After inserting card for Secure Payment, currently gets stuck on payment screen.

image.png

We tried running the card on the Clover register app and it works. It is also working fine on Mini and Station 2018.

Is there any ACTION_SECURE_PAY changes for Station Solo?
Can any one please check this.

Thank you.

PaymentsClover Station
image.png (411.1 KiB)
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

ismdcf avatar image
ismdcf answered

Hi Clover Team,

We are facing the same problem in the Solo as well, where sometimes the screen that is prompted is the below attached screen B. (Which is the correct one)

1635000549114.png


But most of the time it prompts the above screen A in ramya's post, where it gets stuck on the screen with payment items.

What's the reason for these two different payment screens to appear on random times, without any change in the code?


1635000549114.png (419.2 KiB)
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

ismdcf avatar image
ismdcf answered

Hi Team,
Any update on this?

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian answered David Marginian commented

Is this happening on Sandbox only? Or Sandbox and Production? You say this happens at random times? Have you found a way to reproduce it? If you can repro it can you send us the device logs?

2 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Without some more context I am not going to be able to hep. Do you have a date/time the issue occurred? Did the merchant push device logs? Can you reproduce this issue in sandbox?
0 Likes 0 ·
David Marginian avatar image David Marginian ♦♦ David Marginian ♦♦ ·
Device logs must be pushed immediately following the issue or else they won't capture the issue. Did you make this clear to the merchant? Do you have an approximate time period of when this occurred so we can look at those periods in the logs?
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community