question

ramiro avatar image
ramiro asked David Marginian edited

2 different bugs on developer's sandbox

Hello everyone, I'm a new developer here....I want to share with you two different bugs I've found.

1. Trying to complete my profile information on the developer's sandbox I followed the message that states:


"Submit your Developer Account Settings
You'll need to submit your account settings before you can publish apps"


It's mandatory for you to complete your profile, but inside the Developer Account Settings, if you try to open the "Identity Verification" box to add your name, birthday and address the app only shows a white screen with no options (First bug). Opening the browser's console to see what's going on, showed me the following three errors:

1) Error: Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args[]=object%20with%20keys%20%7Blabel%2C%20value%7D&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.


2)Error: Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args[]=object%20with%20keys%20%7Blabel%2C%20value%7D&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.


3)Uncaught Error: Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args[]=object%20with%20keys%20%7Blabel%2C%20value%7D&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.


2. As a second bug: as a Test Merchant, inside the setup menu item, if I try to open the API Tokens option, it will only display the clover logo loading but it will never go away. I just added the two factor authentication, but there's no way to get rid of the loading logo.


Can anybody help whit this please? I'd like to publish an Android app as soon as possible.


SandboxAPI Token
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian answered

For 1, developer accounts are not submitted from sandbox. Sandbox is for testing your app only (https://docs.clover.com/docs/clover-environments). If you see the same thing in production, let me know. For 2, I have seen some other reports of this, but I haven't been able to reproduce it. Are you logged into your developer or test merchant account? If developer, are you logged in as the owner?

You may want to watch some information on our app approval process - https://docs.clover.com/docs/developer-app-approval. Getting your app through our process may take 9 weeks or more.

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

ramiro avatar image
ramiro answered David Marginian edited

Thank you for your quick answer David!

I'll try to learn more about all this topics (I started reading your docs 2 hours ago).... To respond your questions I logged in into the developer's sandbox using my developer account (ingenierorgarrido@gmail.com).... I think I'm the owner since I just opened my account today. Once inside I configured a test merchant named Ena Garrido. My screen looks like this:selection-002.png


By the way, I just found a third bug: Being on the developer account's initial dashboard I simply tried to switch to the test merchant account (Ena Garrido) and a white screen took place....I think it's related to a timeout since switching profiles not always shows a white screen...the browser's console showed me this:

1) Uncaught (in promise) Error: Request failed with status code 400
2) TypeError: Object(...)(...) is undefined
3) Uncaught TypeError: Object(...)(...) is undefined


I think you'd be able to replicate the second bug if you create a new account without a two-factor authentication (I did this process via SMS by the way).


selection-002.png (103.3 KiB)
3 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

When you create a developer account a merchant is automatically created. It sounds like you created an additional merchant. Can you try using the original merchant that was created when your developer account was created? Can you provide the exact steps you took when creating the additional test merchant?

0 Likes 0 ·
ramiro avatar image ramiro David Marginian ♦♦ ·

Well, first of all, I created a new account for the sandbox and after validating the account from my email, I filled the required fields needed for my developer account. Right after I finished, a form to create a test merchant appeard and that's the only merchant I have (Ena Garrido). I haven't created any other merchant... If you look at the picture attached to the message above you'll see I have only my dev account (RGM Soluciones) and only one test merchant (Ena Garrido)....

0 Likes 0 ·

Yeah I was able to log into your account and I do not have a problem accessing the api tokens section. I also created a new account and enabled 2-factor via text and don't have the issue either. I did see a white page a few times and a refresh fixed it each time.

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community