question

LeeMorgan avatar image
LeeMorgan asked ·

Testing OAuth in sandbox. Choosing merchant shows "Not Found"

I am trying to test the OAuth flow in the sandbox. I am able to redirect the user to the Clover login. I log in with my sandbox account, but when I choose my merchant it shows "Not Found" What is the problem here?


I have not submitted or gotten approval for my app yet. Do I need to do that before I can even test OAuth, because that doesn't really make sense to me. Any help is appreciated.

SandboxOAuth
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

David Marginian avatar image
David Marginian answered ·

Update:

I took a look at the information your provided. The merchant id your provided is on Sandbox but the app is in prod. Sandbox and prod are separate environments. You cannot use a merchant id from sandbox and an app id from prod during the OAuth flow.

Original:

Are you certain the client id (app id) is correct?

4 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I just double checked it. The client id is definitely correct.

0 Likes 0 · ·

Please include the app id and your merchant id in a private post. I will look into this early next week if no one else helps you.

0 Likes 0 · ·
LeeMorgan avatar image LeeMorgan David Marginian ♦♦ ·

How in god's name do you do that. I have spent forever trying to simply find the option to do that.

0 Likes 0 · ·
Show more comments

Welcome to the
Clover Developer Community