question

barbatenussapientes avatar image
barbatenussapientes asked ·

DevKit stuck on Factory reset (Factory Tests screen)

Hi, My device is stuck on the Factory Tests screen.

I am trying to get some technical help to pass the 2 remaining failing tests, namely the MSR test and the Barcode Scanner test.

As the other threads suggest, I have called support but after an hour of full circle and back and forth, they can't help because I do not have a Merchant ID I can provide them (because I am on Sandbox).

=> They cannot help with device-related issues if I don't have an active MID (which to me means they don't want to support the developer community which pays for their devKits but that is another discussion).

Can anyone help?

The device is a Clover Mobile 3G (C201).

Thanks, G

DevKit
7 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Can you provide more information on the error you are seeing? If possible pull the complete device logs (adb logcat) and attach a pastebin link.

0 Likes 0 ·

@David Marginian, here is a pastebin of the logcat when trying to run the MSR Test from the screen above. My log level was debug.

https://pastebin.com/wuZe6BgZ

Does that bring any thought?

Thanks!

0 Likes 0 ·

Hi David,

Thanks a lot for the quick reply.

I believe "Factory Reset" got hit, when I start the device, This is the screen I see.
It won't pass it so I tried to go through each individual test to see if once they passed, it would move forward to the setup screen.

So basically, my "error" is the big giant red button that says "Fail".

I will try to attach the device to ABD to acess the adb logcat (assuming this is how you do it).

Thanks!

0 Likes 0 ·

I am not familiar with that error - you may want to ping dev@clover.com.

0 Likes 0 ·

Thanks, I will and update this thread in case someone else has the same issue in the future.

0 Likes 0 ·

Can you give some more details how you wound up on that screen? You think you just factory reset the device? If you reboot, you wind up on that screen? What happens if you press back, home?

Is that you only screen you've seen after the "reset"?

What happens if you do this: "adb shell pm disable com.clover.android.factory.test"?

0 Likes 0 ·

Hi @Jeffrey Blattman, Thanks a lot for the suggestion!

Yes, I got confirmation, that "Factory reset" button got hit before my colleague sent it to me. :/

The screen I have attached it the one that the device boots on.

When the device is off, I press the power button for a couple secomds.

The clover logo shows up and then this screen shows up.

No matter what I do, it will always boot on this screen.

Pressing back or home or the "app manager" button will clear the screen for 2 seconds and then come back to this screen.

Hitting the "Reset" button will re-perform a factory reset and reboot to reach that screen again.

Hitting the "Diagnostics" button will open a separate view with a dozen more test buttons (wifi, camera, light sensor, gps, etc...). I can pass all these one by one.

I can also pass all the tests on the right of the main screen (capture from original post), EXCEPT for "MSR test" and "Barcode scanner test"

"MSR test" simply fails with no details why (I have tried many different MS cards). Logcat here: https://pastebin.com/wuZe6BgZ
"Barcode Scanner test" is apparently expecting me to scan 1 of 4 specific barcodes as the test asks "scan test barcode number 1" or "scan test barcode number 3" the max I've seen is 4. So I am not sure which ones I am expected to scan...

I have tried "adb shell pm disable com.clover.android.factory.test" and this does nothing. same for "adb shell pm disable com.clover.android.factory.diagnostics"?

Here is the specific logcat of when I run the shell pm disable command:

https://pastebin.com/3q4tyKJs

Thanks for your help, I really appreciate!

G

0 Likes 0 ·

1 Answer

David Marginian avatar image
David Marginian answered ·

I got in touch with some of our device folks and unfornately due to the age of this device and the current condition they do not think it can be brought into a working state.

4 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Oh No, :(

Even with some magic "adb" command?

Another thought: Is there a way to edit / manipulate what the factory test is expecting to "simulate" it passes? i.e if the whole thing is just reading a file stored locally that says "pass" or "fail", find it and set it to "pass" ¯\_(ツ)_/¯

Last resort: Do you know if I can trade it in for an equivalent current device somehow?


0 Likes 0 ·

It is a very old device and being able to trade it in doesn't seem consistent with our devkit return/exchange policy. I am the wrong person to ask though, you can send an email to the address I posted earlier and see what they say.

0 Likes 0 ·

I have reached out to them and they said they would contact me.

"Your inquiry is being reviewed and will be assigned to a Technical Solutions Engineer from our Developer Relations team to help assist you further.

Please keep in mind that the Clover Mobile is at end of life and there is very little support for it."

I'm hopeful. :)

Thanks a lot for all your help!

0 Likes 0 ·

Yes to be clear this device is malfunctioning and needs to be replaced.

0 Likes 0 ·

Welcome to the
Clover Developer Community