question

justinsouter avatar image
justinsouter asked morenoh149 commented

adb devices no emulators listed (macOS)

I am unable to see my emulator with adb.

In AS terminal window when I run the command:
adb devices
my configured emulator is not listed.

The command:
emulator -list-avds

shows my configured emulator "Clover_Station_2018_API_28"

Following the instructions under " Emulator Not Listed" doesn't help, and doesn't super make sense because after launching the emulator the command prompt is not returned for the next step until after the emulator is terminated.

My configuration:
macOS 10.13.6
Android Studio 3.2.1
DevKit
2 comments
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

So you have the emulator running but `adb devices` does not list it?
0 Likes 0 ·

Well that seems rather obvious. Now that I run the emulator from the AVD Manager I can indeed see it in the adb devices list! I'm wondering where in the documented steps I missed this. Thanks for the help.

1 Like 1 ·

0 Answers

Welcome to the
Clover Developer Community