question

Pete-UM avatar image
Pete-UM asked ·

TLS 1.2 support on the Clover Station

I'm following up on a post that was created back in January regarding TLS 1.2 support on the Clover Station. Here's the post in question.

At the time it was stated that only TLS 1.0 was supported on the Station due to it being based on Android 4.2. However, Clover indicated that they were looking into adding support for newer TLS versions. I'm inquiring on what the status of that effort is and when we might expect TLS 1.1 or 1.2 support on the Clover Station.

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Brian Murray avatar image
Brian Murray answered ·

We've posted about this on our developer release notes. Once we have have completed the rollout and updated the firmware for all merchants , we will post another update.

As we mentioned in the blog post, please use caution when updating server configurations. A premature change could break app-server connectivity.

UPDATE: As of November 2016, rollout is substantially complete.

8 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Do you have a timeframe on when you expect the rollout will be completed? We want to discontinue TLS 1.0 support on our servers, but cannot do so until the Clover Station supports TLS 1.1 or 1.2.

0 Likes 0 · ·

I'm hoping we can complete the rollout by September 2016.

0 Likes 0 · ·

is the rollout done yet?

0 Likes 0 · ·

Yes, but of course there is certainly some devices out there that have not upgraded, and some that never will.

0 Likes 0 · ·

How is the rollout going? We still have several merchants that are not able to connect to our servers using TLS 1.2 is there a way to manually get the update?

0 Likes 0 · ·
Show more comments

Welcome to the
Clover Developer Community