question

insryuhei avatar image
insryuhei asked insryuhei answered

Payment webhook not being called up on successful Hosted Checkout payment

We are an EC website, and integrated with the Hosted Checkout service. In both sandbox and production environments, we were able to successfully make payments using credit cards. However, the webhook URL we've configured are not getting hit.

We followed this help article to configure the webhook URL: https://www.clover.com/help/customize-checkout-page/#configure-webhooks

Hours and days after successful payments, we checked our IIS log but there were no signs of our webhook URL getting hit. What could we have done wrong?

PaymentsWebhooks
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

insryuhei avatar image
insryuhei answered
We performed an alpha test on our production system, and was able to confirm the webhook back from your production server. Thank you.
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian answered David Marginian converted comment to answer

Hard to say, did it ever work for you in sandbox? Generally, you will want to test and ensure functionality is working in sandbox before moving to production. Can you run a few sample payments through on Sandbox and provide us with your test merchant id and a few payment ids in a moderator's only comment (Expand the Viewable by all users drop down under the submit button)?

15 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi David. Thank you for the prompt reply. Jumping to the conclusion, it never worked on sandbox either. On sandbox, we could find neither “App Settings” nor “Webhooks” mentioned in the article. Then I found a “Webhook” section in; Setup → API Tokens → Configure page, so I pasted our webhook URL and saved. That didn't work either.

If the IIS log shows some sort of records indicating that the ClearPOS server had been hitting us, then there are things we can investigate. However, if we are not getting hit at all then we don't know where to start from.

Are there perhaps rules on the allowed format of the webhook URL? Or, some restrictions on domains we can and can't use?

I have taken out some sensitive information but this is more the less what our webhook URL looks like: https://our.domain.com/index.php/api/webhook/clover/XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX



0 Likes 0 ·

PS. Im running the test now on sandbox account, so give me few more mins to get you the IDs

0 Likes 0 ·
What is your actual domain (I assume not our.domain)? Provide it in a moderator's only comment. Also, give me your sandbox app/merchant config.
0 Likes 0 ·
Show more comments

Welcome to the
Clover Developer Community