question

jkuhn avatar image
jkuhn asked ·

Charge Payment Error

Our Food Truck Pub app was just approved by the app marketplace today. I went in and Published it in Production and was trying to run a few sanity checks. OAuth works fine and I'm getting back a good Access Token and Merchant ID. However, when I call v1/Charge to initiate a charge request, I get an empty response back with no error messages. I tried doing the charge with a test Clover merchant account that I created in Production. I also tested when using the same merchant account that our app is published under. I was thinking maybe it wouldn't let me do a charge if the OAuth information was linked to the same account that my app was published under. However, either way it is not giving me back any response information.


Endpoint that I was hitting as part of ECommerce API: https://api.clover.com/v1/charges

Pay Key: clv_1TSTSvJYzv2MCiWzk5zaFRht (source which is below)


Request:

{ {

"amount": "1291",

"tax_amount": "66",

"tip_amount": "0",

"currency": "USD",

"capture": "true",

"description": "Food Truck Pub order for customer John Kuhn (john@foodtruck.pub)",

"external_reference_id": "FT0000002573",

"source": "clv_1TSTSvJYzv2MCiWzk5zaFRht"

}}

The only information that is coming back is StatusCode: NoContent

Payments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

David Marginian avatar image
David Marginian answered ·

That url is incorrect, you want: https://scl.clover.com/v1/charges.

Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community