question

Paul.Ryan avatar image
Paul.Ryan asked ·

Semi Integration .net 4.0

Hi Team,


Hope You are well



I’ve noticed on here


https://github.com/clover/remote-pay-windows


that it states that .NET 4.5 is required. It also has .NET 4.5 as a minimum requirement on the Nuget package:


https://www.nuget.org/packages/Clover.RemotePayWindows


However, when I download the SDK from here:


https://github.com/clover/remote-pay-windows/archive/master.zip


I can see that all of the projects, including the examples are .NET 4.0.


So my questions are:


  1. Can the version 4 SDK be used with .NET 4.0?
  2. If it can, why does the Nuget package have a dependency on .NET 4.5, and why are the samples using 4.0?
  3. If it can’t, am I ok to use version 3.0.2 of the SDK with the version 2 Clover device? I can see that this one has a dependency on .NET 4.0 and not 4.5.
semi-integrations
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
Paul.Ryan avatar image
Paul.Ryan answered ·

Hi David,


Hope You are well



I’ve noticed on here


https://github.com/clover/remote-pay-windows


that it states that .NET 4.5 is required. It also has .NET 4.5 as a minimum requirement on the Nuget package:


https://www.nuget.org/packages/Clover.RemotePayWindows


However, when I download the SDK from here:


https://github.com/clover/remote-pay-windows/archive/master.zip


I can see that all of the projects, including the examples are .NET 4.0.


So my questions are:


  1. Can the version 4 SDK be used with .NET 4.0?
  2. If it can, why does the Nuget package have a dependency on .NET 4.5, and why are the samples using 4.0?
  3. If it can’t, am I ok to use version 3.0.2 of the SDK with the version 2 Clover device? I can see that this one has a dependency on .NET 4.0 and not 4.5.
3 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

.NET is not my area of expertise. I would certainly recommend that you use the latest Clover SDK as well as the recommended versions of .NET.

1) I would need to ask around about this. Have you tried it? Please do and let me know.

2) I would need to ask around about this.

3) Are you ok? Well you will be missing out on a lot of bug fixes, stability improvements, etc.


0 Likes 0 · ·
Paul.Ryan avatar image Paul.Ryan David Marginian ♦♦ ·

Hi David,


1) I would need to ask around about this. Have you tried it? Please do and let me know. It works but i don't know how stable as I want to check with yourself before completing major testing.

2) I would need to ask around about this. Thanks if you can it would great

3) Are you ok? Yes I'm fine, Hope you are keeping well in this unusual time.

Well you will be missing out on a lot of bug fixes, stability improvements, etc. Taught as much.


Thanks

Paul




0 Likes 0 · ·

My .NET contact is out on vacation for a bit, so you will have to wait awhile for me to get back to you. I am pretty sure for 1 he will say, yeah it will work but not recommended.

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community