question

c716524 avatar image
c716524 asked ·

Setup of emulator

Hi, I am using Android Studio 2.1 on Ubuntu and the goal is to set up an emulator on which I can also install apps of the Clover market, which have been programmed by a third party. I have successfully set up the emulator by using the apks provided from the following source:

Then I had to change the environment using sh target_sandbox.sh by firing the command on Android Studio. The problem however is that I cannot install third party apps with this environment as they are not shown on the app market of the sandbox environment (only the sandbox login credentials worked).

On the other hand I wanted to create an emulator from the following source:

Installation works fine, but when I press "add account" - Clover, there is an error message: "Unfortunately, Clover has stopped".

1) Can anyone confirm that third-party apps can be installed using the developer account and not the sandbox account?

2) What could be the reason for the installation error? (other sandbox apks did also work...)

3) Would it also be an option to change the target environment? (I am not sure what difference there is between the download sites). Then how can I run this file (https://github.com/clover/clover-andr...newenvironment)? It does not work on Android Studio (targetnewenvironment: command not found)

Thanks a lot for any help!

Edit1: The only installation files that work on my emulator are 1100/1809 downloaded from sandbox.dev.clover.com. The bit.ly link provided in your link does not provide apks that work for me (I experienced several crashes - connectionhistory, metrics, launcher etc.). The problem with 1100/1809 is that - as mentioned above - it is not possible to install third-party apps. So by using the targetnewenvironment script (I did not use the right command above as I am a Linux newbie :-) ) I can change to prod_us, but then I get an error ("Clover has stopped") if I want to add the Clover account. I also tried the commands you stated above in Android Studio:

user@host:~/git/clover-android-sdk/scripts$ adb shell sqlite3 -header -line /data/data/com.android.providers.settings/databases/settings.db "UPDATE secure SET value='produs' where name like 'clovertarget'";
root@generic_x86:/ # pm clear com.clover.engine WARNING: linker: libdvm.so has text relocations. This is wasting memory and is a security risk. Please fix. Success

However, it did not change anything. Any other suggestions?

SandboxEmulator
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Jeffrey Blattman avatar image
Jeffrey Blattman answered ·

The developer APK here, https://sandbox.dev.clover.com/v2/apk...

is wrong. It does not target the correct environment (as you figured out). We are working on fixing this.

Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

James Tickett avatar image
James Tickett answered ·

I fixed this using these two commands in adb (after 'adb shell' of course):

sqlite3 -header -line /data/data/com.android.providers.settings/databases/settings.db "UPDATE secure SET value='prod_eu' where name like 'clover_target'";

pm clear com.clover.engine

but where it says 'prodeu' you may want to change to 'produs' depending on your choice of environment. After that you should be able to Add Account again.

I too struggled to get the file/shell script to run but I think its effectively the same thing you're doing. If you still can't get it working check out the answer on this page as it has a download link to a more recent engine apk:

http://devask.clover.com/question/236...

1 comment Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Please do not target developer devices to the prod environment. They should only be targeted at sandbox.

0 Likes 0 · ·

Welcome to the
Clover Developer Community