jhawkzz avatar image
jhawkzz asked bryanvargas commented

“Access denied to package com.our.application” when attempting to call ‘OrderConnector.addDiscount()


We have a private app published and deployed to our Clover POS devices. It has been running without issue since 2020, but as of yesterday, 8-5-23, we’ve begun noticing an issue.

The app is now throwing the exception “Access denied to package com.ccv.ccvperks” when attempting to call ‘OrderConnector.addDiscount()’.

This is on our production systems.

This appears to be related to the most recent Clover Android ROM update, as this was not happening a week ago.

Additionally, today, on 8-6-23, we verified that the app worked fine on our development kit, until we installed the latest ROM updates and rebooted the device. It then began throwing the same error.

For reference, our production environment is running this version:
Model: Clover Station (C500)
Android Version: 7.1.2
Build number: 0 01.10.0562.01.05.0322 (01.00489) SRED Enabled

And our development environment is running this version:
Model: C302U
Android Version: 10
Build number: 9 02.02.1128 02.07.0778 (01.00488) Development

We have attempted to rebuild our app with the latest Clover SDK (293) and Android SDK 33, but still see the same error.

Can you please advise what the appropriate solution is to fix?

Thank you!

OrdersClover Android SDKDiscounts
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

bryanvargas avatar image bryanvargas ♦♦ commented ·

Package manager is not involved in determining Clover permissions. Please make sure your merchant is downloading the app from app market and not having it sideloaded. If the app is installed already, I would recommend uninstalling/reinstalling

1 Like 1 ·
jhawkzz avatar image jhawkzz bryanvargas ♦♦ commented ·

Hi bryanvargas - We did do that. Using our sandbox environment we uploaded a signed APK to the sandbox app market place and had it download directly to our dev kit via the normal "Connect" and then Sync on Device method. No sideloading involved. We received the same error.

Also, it isn't package manager throwing the error, the log is just being explicit in what OrderConnector was denied access to. It appears that under the hood, OrderConnector is issuing an intent that is being blocked, or something along those lines.

0 Likes 0 ·
bryanvargas avatar image bryanvargas ♦♦ jhawkzz commented ·
What is the serial number of the mini you are testing on. And for the Prod account, can you send a secure message of the merchant ID and their device serial number.
0 Likes 0 ·

1 Answer

parquet76 avatar image
parquet76 answered

Bumping this, there is so much spam and dumb ai bots on this forum that legitimate questions get buried.

10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community