question

shahzadkhan avatar image
shahzadkhan asked Christopher Hayes commented

Network Pay Display does not start automatically

Hello All,

We are in process to to intergrade Clover Flex Gen 2 with our .NET base POS and we are using Network Pay Display for integration. Flex is schedule to reboot at daily. Some time it runs network pay display app but some time randomly it stays on passcode screen and ddid not auto run Network Pay display app. We need network pay display app always up and running so pos can communicate with flex instead of manually running Network pay display app on flex. Is there any configuration is required or what is going wrong.

secure network pay display
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian Deactivated answered shahzadkhan commented

SNPD will be started automatically if it was running when the device was rebooted, if not, it won't be.

6 comments
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Yes, it does start but not all the time. This morning when I looked it was on passcode.
0 Likes 0 ·
It is highly likely that you closed the app (4 finger exited) and didn't restart it prior to the device rebooting.
0 Likes 0 ·
shahzadkhan avatar image shahzadkhan David Marginian ♦♦ ·
We will give another try and will post the outcome.
0 Likes 0 ·
Show more comments
Christopher Hayes avatar image
Christopher Hayes answered Christopher Hayes commented

We're seeing something very similar. Attempting to get support from Clover on the phone and we got this statement: "He told us after some investigation that the network pay app requires you to login again were 23 days apart. Louis said there wasn’t a way to refresh the connection via the Clover admin console, it needed to happen on the terminals. "

We are only seeing this happen after an extended period of time.

9 comments
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Sounds like the person you spoke to was talking about pairing, not the auto restart.

0 Likes 0 ·
shahzadkhan avatar image shahzadkhan David Marginian ♦♦ ·

So if it is pairing then silent pairing still work or have pair manually?

0 Likes 0 ·
Christopher Hayes avatar image Christopher Hayes David Marginian ♦♦ ·

That possible; but they did not word it that way - only that they have to start the app again. The issue remains though that after normal reboots where the app was loaded prior to the reboot - the app would reload after the reboot.... after a period of X days (number not yet determined) - they are having to click "start app" (which is what they are reporting). I don't think they are having to re-pair

0 Likes 0 ·
I worked on the semi integration team for several years and I have never heard of that. I am guessing there is some sort of crash that is happening at random times and the app isn't starting up cleanly. The other thing that can trigger this is if the account's email address has changed.
0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community