question

Chris H avatar image
Chris H asked David Marginian answered

Sandbox ecom payment call doesn't seem to be updating order status and not sycning with developer device

sending post to https://scl-sandbox.dev.clover.com/v1/orders/<orderA>/pay

returning status "paid" using body:

{

"ecomind": "ecom",

"customer":"<custid>",

"tip_amount":200

}

get order call ../v3/merchants/<merchant id>/orders/<orderA>

returns state: open


Am i missing something? Example Order Id: TDV3G7DKSMBE4

I'm also not getting updates to physical clover sandbox developer terminal for same merchant



e-commerce api
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian answered

This issue has been resolved.

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David Marginian avatar image
David Marginian answered David Marginian commented

Are you sure you are looking at state and not paymentState? Can you explain what you are doing with this order? Per our logs it looks like you are adding it to via API and the modifying it on the device and then making two payments via API. What is not syncing to the device? The payments?

4 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi David, use case is the following:

  1. Create order via sandbox ecom api
  2. Adds line items to order via Clover Developer Terminal (physical device purchased tied to test merchant in question)
  3. Pay via sandbox ecom order pay endpoint. Payment comes back as paid (successful)
  4. Status not being updated to "locked"

Its like something isn't quite right. This code has been working for a while and seems like something recently changed maybe?

returnedfrompaymentpost.png


getv3orderendptoinstateopen.png





0 Likes 0 ·

Seems like an odd use case. I would have to look at the order in more detail (is it completely paid for, etc.). When did you first notice this and how frequently have you been working on this flow?

0 Likes 0 ·
Chris H avatar image Chris H David Marginian ♦♦ ·

Re Question: "Is it completely paid for?"

Answer: yes I use a token I create and attach to the customer record for payment using the ecom order pay endpoint (see body of first screenshot)

Testing starting yesterday 11/12 for an unrelated coded change for our app, just to regression before pushing to prod. I just tried same flow with order 5MK0K6YQP371P in the sandbox. Same result. Says paid successfully but status not being updated to locked. I have a dev kit I use in conjunction with all my testing for the test merchant and the order never goes paid.

0 Likes 0 ·
Show more comments
David Marginian avatar image
David Marginian answered

Thanks for reporting this. The issue is on our end and we will get it resolved as quickly as possible (likely early next week).

10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community