question

dnalor avatar image
dnalor asked dnalor commented

OrderConnector has stopped working

I have a strange issue lately when interacting with the sdk's OrderConnector.

Been developing an app where I create orders the following way:

  1. Disconnect, then connect to OrderConnector.
  2. Create order: mCreatedOrder = mOrderConnector.createOrder(new Order(orderJSON));

The interesting thing is this has stopped working a couple of weeks ago. The error message is the following: W/ActivityManager: Unable to start service Intent { act=com.clover.intent.action.ORDER_SERVICE_V3_1 (has extras) } U=0: not found

It tries to connect 3 times after that, then throws an exception: com.clover.sdk.v1.BindingException: Could not bind to Android service

What I've tried, but had no luck:

  • Checking my manifest if I miss anything, I have clover.intent.action.ORDER and clover.intent.action.MODIFY_ORDER in there.
  • Trying an older version of my app when this functionality has worked.
  • Set up another virtual device in AVD Manager

What am I missing? Does anybody have an idea where may the problem lie?

Many thanks

Orders
1 comment
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi Dan,

Thanks, using V3 directly did the trick.

I'm using the latest release of the sdk by the way and the app updater is enabled in the emulator, so it seems like it cannot update itself properly.

0 Likes 0 ·

1 Answer

Dan avatar image
Dan answered

Which version of clover-android-sdk and engine are you using? It looks like you are using an older version of engine that does not support the V3_1 order service, and then are using a more recent version of the clover-android-sdk that defaults to the V3_1 order service.

Can try updating engine on your emulator. Alternatively, you can continue to use OrderV3Connector by using it directly (see javadoc in OrderConnector.java).

10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community