question

george.ono avatar image
george.ono asked ·

Clover not attaching CORS headers

Hi,

I'm having a situation that Clover does not attach the CORS headers on response and, as expected, the browser just blocks the response. In my case I am trying to retrieve the devices, but tried other routes with the same result - no CORS headers attached.

I have the necessary permissions, if I do a non-AJAX request I can see the devices, but the CORS headers are not attached.

The strangest part is that with the sandbox it is working as expected, with the same settings (I am referring to OAUth url and CORS url).

Any ideas on this? If this is a known Clover issue, please tell me about it so that I stop hammering for the config and start in another direction.

Thanks, George

Sandbox

image description

Prod

image description

OAuth
2 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

The CORS domain for the app may be wrong. In the app configuration, the section:

Web Settings

Site URL: http://localhost/Payments

Domain: http://localhost

Must be set to reflect the final redirect url for the OAuth process. What is the app name/client id you use for Prod?

0 Likes 0 · ·

0 Answers

Welcome to the
Clover Developer Community