question

khurram avatar image
khurram asked ·

Issue with oAuth in payment REST API

I am trying to create oAuth token via REST API, on sandbox its working correctly however on my live account it gives error, the screenshots are attached. <https://www.clover.com/oauth/authorize?client_id={clientid}> This is the link, when i open it , it takes me to login page, after login it asks to select merchants and upon merchant it gives screen with NOT Found error,

PrintOAuth
1 comment
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I don't see any screenshots!

0 Likes 0 · ·
khurram avatar image
khurram answered ·

@David Marginian yes I am using different id then my send box Id.
I have a test account and that is also a production account and when I am trying to get oAuth token on that then it’s giving successfully but when I try to get from our actual live production account then it’s giving this error.

Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

khurram avatar image
khurram answered ·

@Greg here is the screenshot


1 comment Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

You aren't trying to use the same clientId (app id) that you use on sandbox are you? Your app will have a different id in prod.

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community