question

Dan avatar image
Dan asked ·

Can't get passed new App Updater emulator install

Hi folks, your new App Updater looks like it's going to be a huge improvement for developers, but it's not quite working for me, what would you recommend I do here?
I am using sandbox apks from here:
The only difference from the instructions is that after I added the Clover account and adb reboot, the app updater does nothing by itself. I'm not sure if you are missing a step from the instructions, I had to add the App Updater account manually and turn on sync for it. Then I immediately get the notification to download the apps.

I can see that syncing the account after this failure kicks off the download process again but I can't get passed the first app, it appears to be totally stuck

EDIT:
I think this is a red herring, I am trying to update the apps on an older AVD now via the app updater and they are consistently failing so it looks like there's just something wrong in general with the latest sandbox apks it's trying to download.

App MarketEmulator
capture.png (42.1 KiB)
1 comment
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I am facing a similar issue.
1 Like 1 · ·

1 Answer

Frank Faustino avatar image
Frank Faustino answered ·
Hi, @Dan.

We are aware of the issue affecting Mini, Mini 2nd gen and Flex hardware profiles and are currently investigating the root cause.

I was able to get a Station 2018 emulator set up and going without issue, you could try that in the meantime. We appreciate your patience in this matter.
3 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks Frank I would love to suggest some kind of logcat output when an install fails, I think there's nothing logged in this situation right now. I am used to trying up to about 5 times with over half of the apps individually on the older App Updater before it is happy enough to magically start successfully installing them, and I just figured I would have to do that here as well so ended up wasting a lot of time recreating AVDs etc.. If it hinted at a failure reason I might have been smart enough to abandon ship a little earlier!

0 Likes 0 · ·

Thank you very much for your suggestion! We really appreciate the time you took to think about it and you're absolutely correct, better logcat messages would save developers a lot of time.

0 Likes 0 · ·
madalyn avatar image madalyn Frank Faustino ♦♦ ·

@Frank Faustino Was this ever fixed? I'm getting this issue with the Clover Flex (1st Gen) using com.clover.engine-2048.apk & com.clover.appupdater-1154.apk.

Can you reopen the question or advise the work around for this?

0 Likes 0 · ·

Welcome to the
Clover Developer Community