question

litpro avatar image
litpro asked litpro commented

Web dashboard logging out my developer account

I'm getting an odd behavior when using a developer account of type Admin in the web dashboard (the Owner account works fine). I can log in using this account, but if I select the account menu at the top right -- and maybe before that, actually -- I get a 401 unauthorized on the browser console and I'm logged out. This happens both when logged in as a developer on clover and when logged into the sandbox.
Sandbox
5 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

When trying to install clover on an emulator, the app updater is failing, and I'm seeing a lot of 401 Unauthorized messages in logcat, even when I'm using the Owner account. Not sure whether it's related.

0 Likes 0 ·

I'm receiving the 401 in response to the following GET:

https://sandbox.dev.clover.com/v3/merchants/current/employees/current?expand=roles&includeDeleted=true&_=<some number>

I assume the empty sessionToken cookie I receive is what's effectively logging me out.

Any ideas, Clover people?

0 Likes 0 ·

Sorry to direct-reference you, but @Jeffrey Blattman do you have any idea where I should go next with this?

0 Likes 0 ·

It's not clear to me what is your problem. Is it that you can't login, or that the API is returning 401? This isn't really my area of expertise, but if you can give me steps to easily reproduce I can file an internal issue for you.

0 Likes 0 ·
litpro avatar image litpro Jeffrey Blattman ♦♦ ·

Thank you! Steps to reproduce the in-browser problem: (1) log in with my developer account on the sandbox. this account is a developer sub-account of type Admin, not the Owner account. (2) click the company name at the top right of the screen, next to the person icon. EXPECTED RESULT: See the drop-down menu with a list of test merchants. ACTUAL RESULT: See the dropdown menu with no merchant accounts listed. An error object has been logged to the browser console. Trying to navigate away from the current page shows I have been logged out.

0 Likes 0 ·
Raymond Lee avatar image
Raymond Lee Deactivated answered litpro commented
There is currently no ETA on when a fix will be implemented, but in the meantime, a workaround you can do is add your developer admin account as an employee of the test merchant account you are trying to view. You just need to use the same email you used for the developer admin account for the employee email. That will give you the permission to view that test merchant.
1 comment
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I think I have it set up this way already: I have an owner account with a matching employee created on my first merchant, and I have an additional admin account with a matching employee created. The web interface is (mostly) happy when using the owner account, but quickly logs me out if I do anything with the admin account. Let me know if I should expect a different behavior.

0 Likes 0 ·
Jeffrey Blattman avatar image
Jeffrey Blattman answered Jeffrey Blattman commented

Looks like we are already aware of the problem. It's not been fixed yet (obviously).

4 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Aha! Can you tell me anything about the nature of the problem? I'm having another issue with the updater when installing Clover on an AVD emulator, and if it's unrelated I need to post another thread.

0 Likes 0 ·

I cannot, because I don't know. It's very unlikely your second issue is related, so please post it in a new question.

0 Likes 0 ·
litpro avatar image litpro Jeffrey Blattman ♦♦ ·

Hi, Jeffrey. Just returning to this issue to check on status. Is there an associated ticket anywhere that would allow me to see the current status of this issue?

0 Likes 0 ·
Show more comments

Welcome to the
Clover Developer Community