question

CristianSV avatar image
CristianSV asked ·

Can't connect to Clover Mini device

Hello,

Even though the Clover Mini is connected to the local network (through cable), I am not able to connect to it for debugging.

I'm getting this error: No connection could be made because the target machine actively refused it. (10061)

It works perfectly on the clover stations, but not on the clover mini.

Thanks in advance,
Cristian
Clover MiniDevKit
7 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

What does your setup look like? Have you followed the instructions located here: https://docs.clover.com/build/setup-devkit/#enable-android-debug-bridge ?

0 Likes 0 · ·

Didn't try adding that info to the adb_usb.ini until now, can't find the file though. I created the file in C:\Users\username\.android but it still doesn't recognize the connected device.

Also, shouldn't it be possible to connect to the Mini device through Lan?

0 Likes 0 · ·

A LAN connection allows the device network access, but not much else. To connect to a Clover device for debugging, you'll just need a USB A to B cable (Station is unable to use this method). Once you've plugged into your device, you should see "USB Debugging Connected" in the top left corner of the Mini. If not, you may have disabled USB debugging and will need to do a Factory Reset.

1 Like 1 · ·
Show more comments

Yes, you can use network debugging with Clover devices per standard "adb tcpip..." function.

0 Likes 0 · ·

1 Answer

prasaddhana avatar image
prasaddhana answered ·
Done all the steps as you said using below links

https://developer.android.com/studio/debug/dev-options.html#enable
https://developer.android.com/studio/debug/dev-opt...

but device not detecting in device manager of my system, Enabled USB debugging in clover device and done reset factory settings also.. nothing happened, Using A to B cable -> device connected -> USB debugging connected -> but not showing in System device manager and device not listing under ADB devices command from terminal as well as from android studio run.. i have road block here to debug my application in alpha level, please help
1 comment Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Have you added the information to adb_usb.ini?

0 Likes 0 · ·

Welcome to the
Clover Developer Community