danishn avatar image
danishn asked sreekant commented

Issues with Station 2018 emulator setup

I am trying to set up Station 2018 emulator using engine APK com.clover.engine-2077.apk. As original APK (om.clover.engine-2126.apk) posted on official documentation does not work and its pointing to STG environment instead of Sandbox or Dev

An emulator is set up and Engine APK is also installed. However, when I am trying to run the Updater script and sync with the merchant portal (& stuff) - the updater app fails to run/complete with the below error/logs.

% ./
Getting installed versions...
Getting current app data...
Updating package: com.clover.payment.core from version: ?, to version: 32...
/Android/sdk/platform-tools/adb install --no-streaming -r -d /var/folders/qc/kfm32p_n19ngt2zs_c8ssb0r0000gn/T/com.clover.payment.core-32.apk >>> Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]
/Android/sdk/platform-tools/adb install --no-streaming -r -d /var/folders/qc/kfm32p_n19ngt2zs_c8ssb0r0000gn/T/com.clover.payment.core-32.apk >>> Performing Push Install
/Android/sdk/platform-tools/adb install --no-streaming -r -d /var/folders/qc/kfm32p_n19ngt2zs_c8ssb0r0000gn/T/com.clover.payment.core-32.apk >>> /var/folders/qc/kfm32p_n19ngt2zs_c8ssb0r0000gn/T/com.clover.payment.core-32.apk: 1 file pushed, 0 skipped. 88.7 MB/s (13707086 bytes in 0.147s)
APK file kept at: /var/folders/qc/kfm32p_n19ngt2zs_c8ssb0r0000gn/T/com.clover.payment.core-32.apk
Updating package: com.clover.apps from version: ?, to version: 1364...
Updating package: com.clover.appupdater from version: 1147, to version: 1172...
Updating package: com.clover.auths from version: ?, to version: 165...
Updating package: from version: ?, to version: 58...
Updating package: com.clover.cashmanagement from version: ?, to version: 1137...
Updating package: com.clover.remote.protocol.local from version: ?, to version: 360...
Updating package: com.clover.closeout from version: ?, to version: 150...
Updating package: com.clover.connmon from version: ?, to version: 81...
Updating package: com.clover.crypt from version: ?, to version: 2126...
Updating package: com.clover.customers from version: ?, to version: 1227...
Updating package: com.clover.employees from version: ?, to version: 1232...
Updating package: com.clover.engine from version: 2077, to version: 2126...
Updating package: from version: ?, to version: 389...

Also, when I am trying to run an example app for Custom Tender (, it gives an error while registering/launching the app.


After looking for some solutions around, looks like there are few bugs with engine APK or setup that might cause an issue, so reaching out for help to achieve an e2e setup. FYI, the same setup actually worked on the emulator setup for Station.

EmulatorClover Station 2018
image-1.png (121.9 KiB)
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

adil avatar image
adil answered sreekant commented

how did u solve this?

10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

danishn avatar image danishn commented ·
I am still facing this issue
0 Likes 0 ·
David Marginian avatar image David Marginian ♦♦ danishn commented ·
We pushed engine 2131 yesterday and updated the docs, the issue has been resolved.
1 Like 1 ·
danishn avatar image danishn David Marginian ♦♦ commented ·
Thanks for update. The new build seems working but we are still not able to get python script running successfully for "Custom Tender" example app.

Any thoughts on the same?

0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community