question

wsadiq avatar image
wsadiq asked dazza5000 commented

Getting No token type: com.clover.account.token.app

Hello,


I know that this has been posted by others as well but almost everyone who has posted has been talking about emulator. I am getting this error on my Clover dev kits (Clover Station 2018 and Flex).


I have tried everything, including resetting my devices.


The strangest thing is that my application has been on Clover marketplace for the last 4 years so this is not a new account or application. Everything had been working fine until very recently.


Please see the following snippets.


Code: https://bitbucket.org/snippets/kikkle/qnz56x/cloverapputiljava

line 68 shows the account object being obtained and line 159 shows attempt to obtain the auth token.


logcat: https://bitbucket.org/snippets/kikkle/EbGxjx/logcattxt

line 277 shows the relevant messages.


There are a few things to note. This app is in production. The last release was built in January 2019 and is being successful used by many clients. New accounts are also being created as recently as yesterday.


I have taken the same code from github and rebuilt and deployed it on my Clover Station 2018 DevKit and it does not run anymore. I have tried to build with clover android sdk build 228.3 as well as latest release with same result.


I am very puzzled as to what has changed.


One thing I do notice is a special character in the email name in the obtained account. I have not changed any of my account settings in years so not sure if that is significant or not.


Any help or insight would be greatly appreciated. This has made it difficult to add new enhancements to my application because I have no way of testing in a proper environment.


look forward to hearing from Clover heavy eights out there.

Clover FlexAPI TokenClover Station 2018
17 comments
10 |2000

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Is the app installed to the merchant? Was it installed by Clover's App Updater app?

0 Likes 0 ·
wsadiq avatar image wsadiq Jeffrey Blattman ♦♦ ·

Hi Jeffrey,


I am not sure if i understand question correctly. Our app is 4+ years old. We have hundreds of merchants using it. We are not having the problem with the app in production.


The problem is only happening in our sandbox environment and on the dev kits. The problem only started happening a month or so ago. We do have our app in the sandbox marketplace for a longtime but we normally sideload the app through android studio.


Your help is greatly appreciated because we are dead in the water right now.

0 Likes 0 ·

The app must be installed through the app market if it is to get a token. The services on the device will not give it a token otherwise. The typical workflow is to install through the app market, uninstall via adb, then sideload via adb for development.

0 Likes 0 ·
Show more comments

What's your target SDK & Compile SDK version?

0 Likes 0 ·

0 Answers

· Write an Answer

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Welcome to the
Clover Developer Community