question

bobbygill avatar image
bobbygill asked ·

"Show In Register" set to false, but items are showing in Register

This is a new issue we just noticed in the past week. If we create an inventory item it appears the "Show in Register" item is not being honored by the Register app. If we create a inventory item in the Inventory app and leave "Show in Register" unchecked OR if we programmatically create it and setHidden = true, in both cases those items are now showing up in the Register app. Previously both of these options worked to hide items from the Register app but it looks like something has changed recently on the Clover device where all inventory items are being shown in the Register, regardless if they have been marked as "hidden".

Can someone from Clover confirm whether this is now expected? Or is this a bug?
Inventory
2 comments
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hello @bobbygill,
Are you still experiencing this issue? It does not seem to be a bug- I have attempted to reproduce this in both production and sandbox environments and the `Show in Register` flag is working as expected.
0 Likes 0 · ·
bobbygill avatar image bobbygill Lauren Worthington ♦ ·

Hi Lauren, we are still seeing this on multiple sandbox and production machines. We've made a video showing the issue, please see here:

https://www.dropbox.com/s/rnll9nbi1jvwxp0/ShowInRegister.mp4?dl=0

0 Likes 0 · ·

1 Answer

Lauren Worthington avatar image
Lauren Worthington answered ·
Thank you for providing the video example, that was very helpful. After doing some more testing, it looks like selecting `Hide From Register` currently hides it from the category view in the registerif the item is in a category, but does not hide it from the `All Items` view. This does seem to be a bug and I have brought it to the attention of the correct team.

Edit- Clover is already aware of this bug and will be fixed in an upcoming release.
2 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thank you for the follow up Lauren. Is there any ticket number or way I can track the status of the fix for this issue?

0 Likes 0 · ·

There isn't a ticket number trackable by the public, keep an eye on release notes as the fix will be stated there.

0 Likes 0 · ·

Welcome to the
Clover Developer Community