question

yarrumretep avatar image
yarrumretep asked ·

Configuring Emulator

I've been trying to get various flavors of sandbox emulator running using the steps at this page: https://docs.clover.com/clover-platform/docs/setting-up-an-android-emulator

These steps worked OK for a Station 2018 configuration, but I'm getting wedged with the mini and flex configurations. Here's a screenshot of a Flex installation I just tried from scratch. Is it possible that it's trying to install incompatible apps? How can I configuration multiple different emulators to exercise my application for all platforms?

EmulatorUSB Pay Display
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Emily L avatar image
Emily L answered ·
This is a known bug on Clover’s end that’s occurring on all Sandbox emulators. App Updater hangs while going through the installation process.

Until this is addressed, the current workaround is to download and install the desired apps from the Clover Applications page. You can do this the same way you installed the Clover Engine and App Updater, or you can create a shell script along the following lines to download and install everything for you:

array=(
  # list the packages you want to download; for example:
  com.clover.appupdater-1147.apk
  com.clover.engine-2023.apk
  com.clover.crypt-2023.apk
  # etc.
)
for i in {0..[arrayLength]}
do
  echo "Downloading ${array[i]} ..."
  wget https://filessandbox.dev.clover.com/v2/apk/${array[i]}
  adb install ${array[i]}
done
2 comments Share
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

fyi I actually tried this and the SDK would not give me legitimate tokens, so it might not work for you @yarrumretep

0 Likes 0 · ·

What tokens or functionality are you having trouble with? I’ve been able to successfully generate API tokens with the SDK and use the different connectors on an emulator.

What is the specific behavior you're coming across? If you aren’t getting legitimate tokens, are you getting tokens that don’t work, is something returning null, or is something crashing your app and leaving a stack trace?

0 Likes 0 · ·

Welcome to the
Clover Developer Community