Chetan Bhatia avatar image
Chetan Bhatia Posted · · Frank Faustino edited ·

RESOLVED: Known login issues on the emulator - September 13th, 2019

UPDATE: The 401 Unauthorized issue was fixed however there is an issue with App Updater not installing the necessary Clover apps. We're actively working to fix this issue and will keep this post updated with the latest.
We are aware of login issues on the emulator. Currently, if you try to login with your test merchant account credentials on the emulator, you receive a 401 Unauthorized response.

As a temporary solution, remove the current version of the Clover Engine app and then install version 2022 of the app:

A more permanent fix will roll out early September 2019. We will follow up when we have more information.
10 |2000 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.


Ok, what do we do in the meantime? In this link I can see the latest apps listed. Should do we download a previous version? What's the link?

Thank you

0 Likes 0 · ·

I found a temporary solution:
remove your current clover engine app, then download the older version:
install it then login again, it should work

0 Likes 0 · ·
Show more comments

Hi, it doesn't work for me. It says 'invalid credentials' when I can login to my account from a browser.

0 Likes 0 · ·

found it! appupdater version 1131 with engine version 2022 works!
As a workaround at this moment we can use these packages:

0 Likes 0 · ·

mmm... this still not working! I still get a 401 error when trying to log in into my sandbox account from the emulator while I'm configuring it!

Have you updated the engine and appupdater apk? could you let me know where the new links are?

0 Likes 0 · ·

I followed this guide and downloaded the apks from here

When I need to login with Clover from into the emulator a 401 error is displayed. Image attached.screenshot-2019-09-03-at-101313.png

What was fixed?

0 Likes 0 · ·

I've created a new mobile emulator with the suggested pacakge engine-2022 and appupdater-1153. I managed to login but after reboot the device, no apps are being installed, there's no notification, nothing happens.

This part of the guide is failing:

The emulator reboots. When the emulator powers on, the Clover base apps are synced to the emulated device. This process may take several minutes as all of the apps are downloaded. Download progress can be seen in the Clover App Updater notification. Wait until the notification says Updates are installing.

Because the current version of engine is 2044 and you suggest to use the version 2022, I've rested 22 to the appupdater and I've downloaded the version 1131. I manage to log in and the apps started to download after reboot, BUT during the install, I've received the following error message: There was a problem parsing the package.


This is getting very frustrating as the help is not helping, the documentation steps are not working and there's not much activity on this.

Could you try to create a mobile emulator from scratch and let us know the steps taking into account the current issue?
We are trying to build an MVP but we got stuck with the emulator, which is a shame!

0 Likes 0 · ·

The same happens when trying to create a mini 2nd gen emulator. The notification never appears after reboot!

0 Likes 0 · ·

Is this effecting production (US) emulator as well

0 Likes 0 · ·

Yes, 2022 for clover engine and 1131 updater for the production environment worked as expected

appupdater ->

clover-engine ->

0 Likes 0 · ·

There are several ways to generate an emulator and not all of them are working with the suggested solution!

Creating an emulator for mobile on a sandbox account is definitely not working. I'm tired to create over and over again the emulator with the same results.
The notification never appears, apps are not being installed, could you help on this?

0 Likes 0 · ·

I saw you uploaded a new engine version 2045! I've tested it and I'm facing a new error after rebooting the emulator.screenshot-2019-09-09-at-123658.png

0 Likes 0 · ·

We are unable to open the Register app and if we do it loads infinitely, is this a problem with the App Updater? I've noticed we are unable to update some apps as well. It looks like this article hasn't been updated for about a week now, has this issue been moved to another article?

0 Likes 0 · ·


We are facing an issue where we are stuck with the following version for the clover emulator

appupdater ->

clover-engine ->

Installing the latest version of the above apps from would not install any apps on the emulator after signing in with the clover account. Installing the above-specified version we are stuck with our sandbox app not updating or uninstalling the app from sandbox, we need to create the emulator from scratch if we need to update or reinstall our app.

Please be kind enough to provide a timeline for the fix.

1 Like 1 · ·

Hi Is there a fix for this. As we are facing an issue with the latest

We're unable to set up the emulator. The login failed with message check credentials. If I try to use an older version of the app engine after the apps are installed the clover engine is also updated to the latest (2087) and after that rest of the apps like app store are not working. Maybe engine was build to a wrong environment like mentioned here

We've tried setting up the emulator around 10 times with different combinations and still no success

0 Likes 0 · ·
Show more comments

Welcome to the
Clover Developer Community



frank.faustino contributed to this article chetan.bhatia contributed to this article sreya contributed to this article rachel contributed to this article